System Requirements

Composer can be downloaded and installed in different Linux distributions. You can also deploy Composer in the cloud. To try Logi Composer for free, check out our Free Trials page.

The client application is accessed using web browsers that support web socket technology. See caniuse.com to check whether your web browser supports web socket technology. The following requirements are needed in order to successfully deploy and access the Composer Server in your operating environment.

See also Installation Prerequisites.

Operating System and Software Requirements

For Linux deployments, 64-bit Linux-based OS is required. The following table shows the Linux distributions supported along with the corresponding minimum supported version. Composer Server also uses Java, PostgreSQL, and Spark. Ensure that the appropriate version of these tools are used in the deployment of Composer in your operating environment.

Distribution Supported Version
CentOS 6.x, 7, & 8
Red Hat 6.x, 7, & 8
Scientific Linux 6.x
Ubuntu 16.04 LTS, 18
PostgreSQL 12
Java 11.0.5 (or later)
Spark 2.2

Important CentOS 6 Information

Support for CentOS 6 will be deprecated when it is no longer supported by Red Hat Enterprise Linux (RHEL).

If your environment is running CentOS6, a special installation Bootstrap procedure, called bootstrap-zoomdata-centos6.run, must be used to install or upgrade to Composer 5.9 or later. The regular Bootstrap procedure will fail in CentOS 6 environments.

In addition, if your environment is running CentOS 6, you must manually install OpenJDK 11. OpenJDK 11 is available from various vendors, such as AWS Corretto, OpenJDK11, or Oracle JDK11. See Manually Installing OpenJDK 11.

When you attempt to install or upgrade Composer in a CentOS 6 environment that does not have OpenJDK 11 installed, the installation script will start, but will produce FAIL messages during its execution because of the missing OpenJDK 11 software. When the installation script runs, the Composer binaries are upgraded to the latest version, but you will not be able to start Composer without first manually installing OpenJDK 11.

Important Ubuntu Information

Ubuntu users who have Composer or Zoomdata versions earlier than 5.8 installed must first remove the legacy repository before upgrading Composer 5.8 or later. Use this command:

sudo rm -f /etc/apt/sources.list.d/saltstack.list

Hardware Requirements

For RPM and Ubuntu installations, the following server specifications are recommended:

  • 64 GB RAM (minimum is 16 GB)
  • 500 GB disk space
  • 16 cores

See also Sizing Guidelines.

Metadata Repository

Composer uses a packaged PostgreSQL v12 database instance to store its metadata and strongly recommends using this instance due to the specific configuration and version employed. If you would like to use another PostgreSQL instance, contact Technical Support for further guidance.

Network Requirements

Ports

The following table lists the ports you must consider when installing or upgrading Logi Composer.

Composer Feature Microservice Default Port Required? Notes
Composer server zoomdata 8080 P  
Composer server zoomdata 8443, 443 O Required only if you use HTTPS
Consul zoomdata-consul 8500 P  
Query Engine zoomdata-query-engine 5580 P  
Appropriate Composer connectors zoomdata-edc-<connector> varies P Only the ports for the Composer connectors to the data stores you will use are required. For a complete list, see Composer v5 Data Connector Reference.
Data Writer zoomdata-data-writer 8081 O Required only if you use flat file or Upload API sources.
Screenshot Service zoomdata-screenshot-service 8083 O Required only if you schedule dashboard reports.
PostgreSQL metadata repository zoomdata-postgres 5432 P  

Time Synchronization

Composer recommends installing the Network Time Protocol daemon (NTPD) to allow for time synchronization of networked servers to Coordinated Universal Time (UTC), if not already available in your network. See Using the Network Time Protocol to Synchronize Time for guidance.

Supported Browsers

Due to the WebSocket technology that Composer uses, you need to use one of the following browsers to access the client application.

Windows 7+

  • Chrome 49+ (recommended)
  • Firefox 45+
  • Edge 14+

Mac OSX 10.10+

  • Chrome 49+ (recommended)
  • Firefox 45+
  • Safari 9.1+

iOS 9+ on iPad

  • Embedded Safari Browser

Android 6+

  • Embedded Chrome Browser