CLI Support Table

The following table lists the version of the CLI supported by different versions of Zoomdata and Composer.

CLI Version Supported Zoomdata/Composer Versions
4 Zoomdata 4 and Composer 5.9 and earlier
5 Composer 5.9.1 and later

For information about migrating your existing custom charts to version 4.0 format, see Migrating Custom Charts. You can get additional information about the CLI at https://www.npmjs.com/package/zoomdata-chart-cli. A step-by-step tutorial for creating a custom chart can be found in the Composer version 6 documentation at this link: https://documentation.logianalytics.com/cmp/content/topics/custom-chart/custom-chart-tut-ov.html.