Logi Composer Version 5 Release Notes

These release notes cover changes and fixes made to Zoomdata and Composer 5 releases. The latest updates are available in version 5.9.10. You can identify your release version on the login screen.

For information about the supported Logi Composer and Logi Zoomdata releases, see Logi Composer (Zoomdata) Release Vehicles.

Important CentOS 6 Information

Support for CentOS 6 will be deprecated when it is no longer supported by Red Hat Enterprise Linux (RHEL).

If your environment is running CentOS6, a special installation Bootstrap procedure, called bootstrap-zoomdata-centos6.run, must be used to install or upgrade to Composer 5.9 or later. The regular Bootstrap procedure will fail in CentOS 6 environments.

In addition, if your environment is running CentOS 6, you must manually install OpenJDK 11. OpenJDK 11 is available from various vendors, such as AWS Corretto, OpenJDK11, or Oracle JDK11. See Manually Installing OpenJDK 11.

When you attempt to install or upgrade Composer in a CentOS 6 environment that does not have OpenJDK 11 installed, the installation script will start, but will produce FAIL messages during its execution because of the missing OpenJDK 11 software. When the installation script runs, the Composer binaries are upgraded to the latest version, but you will not be able to start Composer without first manually installing OpenJDK 11.

Important Ubuntu Information

Ubuntu users who have Composer or Zoomdata versions earlier than 5.8 installed must first remove the legacy repository before upgrading Composer 5.8 or later. Use this command:

sudo rm -f /etc/apt/sources.list.d/saltstack.list

See the following Release Notes for different releases of version 5:

For information about CLI support, see CLI Support Table. For information about Composer features that have been deprecated over the last several versions, see Deprecated Features.

Email salesteam@logianalytics.com to purchase Composer.

For information about Composer's end-of-life policy for third-party software, see Composer's Third-Party End-of-Life Policy.

Migration Considerations

  • Before installing or upgrading to any Composer 5.9.x version, please read Composer 5.9.x Installation and Upgrade Process for Multiple Context Paths.

  • Manually upgrading Composer no longer provides the Java Runtime Environment (JRE) needed for Composer to start. Make sure you have Java 11.0.5 or later installed before you manually install or manually upgrade to Composer 5.8 or later. If you do not, Composer will not start.

  • Due to the upgrade of the HashiCorp Consul (service discovery) version from 0.7.5 to 1.2.2, custom connectors built before Zoomdata 3.2 ( built for versions 3.1 or earlier versions) will not appear after you migrate to Zoomdata 3.7 (or later) or to Composer 5 (or later). This is caused by incompatibilities between old connectors and the new Consul. To make your custom connectors compatible with Zoomdata 3.7 (or later) and Composer 5 (or later), you must migrate the connectors as described in Custom Connector Migration.

    This migration step is required only for custom connectors built with Zoomdata versions earlier than 3.2 or for connectors that were present before Zoomdata 3.2 but that are now deprecated (for example, the Hive on Tez connector, which was replaced by the Hive connector in Zoomdata 3.7).

  • Zoomdata version 3.2 (or later) and Composer 5 (or later) versions use headless Google Chrome instead of Firefox for the Screenshot microservice. The Chrome-based Screenshot microservice cannot be installed in CentOS 6 environments because the Google Chrome dependencies do not support that platform. See Setting Up the Screenshot Microservice.