Version you are viewing: Zoomdata v4

Zoomdata v5

Zoomdata v3

Zoomdata Version 4.8

The following enhancements and updates were made to Zoomdata in version 4.8. See the following topics:

Click https://www.zoomdata.com/contact-us/ to purchase Zoomdata.

Connector Changes

  • Support for Impala versions 2.5 and 2.6 are deprecated in this release. The minimum version of Cloudera Impala that is supported is now 2.7. See Managing the Impala Connector.

  • Support for Elasticsearch version 5 is deprecated in this release. The minimum version supported is now 6.0. See Managing the Elasticsearch Connector.

  • Support for MemSQL version 5.0 and 5.1 are deprecated in this release. The minimum version supported is now 6.0. See Managing the MemSQL Connector.

  • Support for SparkSQL versions 2.0 through 2.2 are deprecated in this release. In addition, support for SparkSQL versions 2.3 and 2.4 are added. See Managing the Spark SQL Connector.

Chart Updates

The bar chart types were updated in this release and now render using the latest version of the ECharts library. Bar charts include standard bar charts, histograms, and multiple metric charts. For more information about bar charts, see Bar Chart Styles.

Field Changes

The following changes have been made to field manipulation in this release:

  • You can now use derived fields in WHERE clauses in custom metrics. In prior versions, derived fields could not be used. See Supported SQL-Like Expressions.

  • Hidden source and derived fields can now be used in other derived fields. Note that they still cannot be used in custom metrics or in dashboard charts. See Hiding Fields.

What's Fixed?

The following problems have been fixed in this release.

  • Corrected a problem in which the dashboard scroll bar was missing when using the Internet Explorer version 11 browser.

  • Corrected a user interface display problem that occurred when a user was added to multiple groups with long names.

What's Deprecated?

The following features are deprecated in this release.

  • Support for Cloudera Impala versions 2.5 and 2.6 are deprecated in this release.

  • Support for Elasticsearch version 5 is deprecated in this release.

  • Support for MemSQL version 5.0 and 5.1 are deprecated in this release.

  • Support for SparkSQL versions 2.0 through 2.2 are deprecated in this release.

To review a history of deprecated features, see Deprecated Zoomdata Features.