Version you are viewing: Zoomdata v3

Zoomdata v4

Zoomdata v5

Configuring the Maximum Number of Open Processes and Files

If you are installing Zoomdata on a server running either CentOS v6 or Ubuntu v14, Zoomdata recommends that you configure the maximum number of open processes and open files that can run in your operating environment. These settings keep Zoomdata processes from hitting or exceeding the resource limits that may be imposed by your operating system.

Be sure to complete this prerequisite setup before installing Zoomdata. If your server is running either CentOS v7 or Ubuntu v16, then you can skip this prerequisite step.

Instructions are provided here for the following operating environments:

CentOS 6 Instructions

These steps are also correct if you are installing Zoomdata via tarball scripts.

  1. Use the following command to access and open the limits.conffile. If the configuration file does not exist, this command creates it.

    vi /etc/security/limits.conf
  2. Add the following lines to the file:

    zoomdata soft nproc 4096
    zoomdata hard nproc 4096
    zoomdata soft nofile 10000
    zoomdata hard nofile 10000
  3. Save and exit the configuration file.

CentOS 7 Instructions

If you are installing via RPM using CentOS or Red Hat, the recommended settings differ slightly. Because systemd is responsible for starting the various Zoomdata services, you need to amend the files and services that are launched so the limits.conf file is not ignored.

Zoomdata recommends that you create an override directory specifically for the services you want to override.

  1. Create a new systemd directory:

     mkdir /etc/systemd/system/<servicename>.service.d/

    Replace <servicename> with the service you need to override.

  2. The file name for the service you want to override needs to be in .conf, so use the following command:

    touch /etc/systemd/system/<servicename>.service.d/<servicename>.conf

For more information about managing services for Red Hat, see the Red Hat documentation.

If Zoomdata stops operating and you receive the error message too many files, cannot operate, you may need to increase the system limits in your CentOS v7 or Ubuntu v16 environments. Make the following changes:

  1. In the service.d folder for each microservice, open the limits.conf file. If the configuration file does not exist, this command creates it.

    vi /etc/systemd/system/<servicename>.service.d/limits.conf
  2. Add the following to the file:

    [Service]
    LimitNOFILE=10000
  3. Restart the init service:

    systemctl daemon-reload
  4. Restart the zoomdata service:

    systemctl restart zoomdata.service
  5. Verify your changes were applied:

    ps -ef | grep zoomdata-web | grep -v grep | awk '{system("cat /proc/"$2"/limits")}' | grep -i "Max open files"
  6. In the output, you should see the following, indicating that your changes were applied:

    Max open files            10000                10000                files

Return to the installation topic you are using to continue the installation process: